Issue installing the 11gR2 database software after the 12.1.0.2 clusterware setup

If you don’t plan to install the 11gR2 database software after a 12.1.0.2 clusterware installation, I guess there is no need for you to read this post.

I just want to share the issue I got and the way you could workaround it. The purpose of this post is just to save your time, in case of.

So, after a 12.1.0.2 clusterware installation (on a 2 nodes RAC cluster), I decided to install the 11.2.0.4 database software. I launched the runInstaller, followed the install process until the Step 4:

install11g_db

As you can see the nodes that are part of the cluster have not been proposed and clicking next would produce “CRS is not installed on any of the nodes”. 

The first question you may ask is: Is the 11gR2 database compatible with CRS 12.1? Yes it is, as you can see here:

crs_supported_version

As I am curious, I canceled the 11gR2 database software installation and gave a try with the 12.1.0.2 database software. The Step 4 produced:

install12c_db

As you can see the nodes that are part of the cluster have been proposed.

I canceled the 12.1.0.2 database software installation and I had a look to the Inventory. Then I discovered that the CRS=”true” flag was not set for the 12.1.0.2 GI HOME:

$ cat /etc/oraInst.loc | grep inventory_loc
inventory_loc=/ec/poc/server/oracle/olrpoc1/u000/oraInventory

$ cat /ec/poc/server/oracle/olrpoc1/u000/oraInventory/ContentsXML/inventory.xml
..
HOME NAME="OraGI12Home1" LOC="/ec/poc/server/oracle/olrpoc1/u000/product/GRID.12.1.0.2" TYPE="O" IDX="1"
..

Then I added the the CRS=”true” flag that way:

$GI_HOME/oui/bin/runInstaller -updateNodeList ORACLE_HOME="/ec/poc/server/oracle/olrpoc1/u000/product/GRID.12.1.0.2" CRS=true

So that:

$ cat /ec/poc/server/oracle/olrpoc1/u000/oraInventory/ContentsXML/inventory.xml
..
HOME NAME="OraGI12Home1" LOC="/ec/poc/server/oracle/olrpoc1/u000/product/GRID.12.1.0.2" TYPE="O" IDX="1" CRS="true"
..

Then I relaunched the 11.2.0.4 database software installation, and the Step 4 produced:

install11g_db_fixed

As you can see the nodes have been proposed so that I have been able to complete the installation successfully.

Remarks:

  1. MOS 1053393.1 provides more details about the CRS=”true” flag.
  2. I guess the “issue” will be the same for database software >=10.1 and < 12.1 (But I did not test it).
  3. On another RAC, I upgraded the GI from 12.1.0.1 to 12.1.0.2 and then the CRS=”true” flag has been set automatically for the 12.1.0.2 GI.

Conclusion: After a 12.1.0.2 CRS installation,

  1. You may need to put the CRS=”true” flag to avoid this issue during a 11gR2 database software installation.
  2. You don’t need to put the CRS=”true” flag during a 12.1.0.2 database software installation as the issue does not appear.
  3. It looks like you won’t hit the issue if the GI has been upgraded to 12.1.0.2 (See third remark).
Advertisements

One thought on “Issue installing the 11gR2 database software after the 12.1.0.2 clusterware setup

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s